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About Dolphin and this document

Dolphin application Copyright © 2006–2015 Peter Penz, Frank Reininghaus and Emmanuel Pescosta. Go to 
Help > About Dolphin, or refer to the official Dolphin Handbook for up-to-date credits and license information, 
and a more complete list of contributors.

A comprehensive guide to the Dolphin file manager by David Both and Pierre4L - version 1.0 - 2016-01-13

This document was created using LibreOffice. It is published under a Creative Commons Attribution-
ShareAlike license.

An original, concise version of this document appeared as an article on opensource.com, written by David 
Both, with an additional version published on his site, DataBook®. This expanded and reformatted version 
was edited by Pierre4L under the terms of the original's Creative Commons CC-BY-SA license.

DataBook is a registered trademark of David Both.

Dolphin icons courtesy of Wikimedia Commons, available freely under the terms of the GNU General Public 
License and the GNU Lesser General Public License.

The Dolphin Plasma blue splash cover logo was created by Pierre4L, using elements of the "Horizon" 
Plasma desktop wallpaper by Ken Vermette, and free clip art from clker.com. It is made available under a 
Creative Commons CC-BY-SA license (see above).

Screenshots were captured by both authors on various installations of Dolphin running under both Plasma 4 
and Plasma 5 environments.

David Both (https://twitter.com/linuxgeek46) is a Linux and Open Source advocate who resides in Raleigh, 
North Carolina. He has been in the IT industry for over forty years and taught OS/2 for IBM where he worked 
for over 20 years. While at IBM, he wrote the first training course for the original IBM PC in 1981. He has 
taught RHCE classes for Red Hat and has worked at MCI Worldcom, Cisco, and the State of North Carolina. 
He has been working with Linux and Open Source Software for over 15 years. David has written articles for 
OS/2 Magazine, Linux Magazine, Linux Journal and OpenSource.com.

Pierre4L (https://twitter.com/Pierre4L) has been a Linux and KDE user for over a decade. As communications
administrator for a former employer in the UK, he was responsible for the overhaul of all company 
information resources and the creation of an Intranet system to house them. This entailed using a secret 
Linux server installed in the kitchen of the company's plant on the other side of the continent in order to 
circumvent the stranglehold imposed by the contractual obligations of the outsourced IT department. Now 
residing in France, his occasional forays into writing include a web-based novel, and he is pursuing a new 
book about his experiences.

For further information or contributions pertaining to this document, contact the authors via the links above.
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Introduction

Dolphin is a file manager application developed by members of the KDE community. It has for many years 
now served as the premier tool of its kind for the Plasma Desktop created by the KDE project. It's very 
powerful and provides many advanced features, whilst retaining an interface that is not too complicated.

Having begun as a detachment from the all-encompassing Konqueror file/web browser, an early version of 
Dolphin was available as an optional component for KDE 3 (later becoming known as "D3lphin"). With the 
release of KDE 4 in 2008, Dolphin became the default file manager in various Linux distributions and Unix-
like operating systems. The most up-to-date Dolphin is now developed for use with Plasma 5.

Like most KDE Applications, Dolphin can be used under other desktop environments such as GNOME or 
Xfce, which may require additional dependent files to be installed. Some KDE libraries and applications have
been ported to other operating systems, so it is possible to use Dolphin under BSD. Versions have also been
released previously for use under Solaris, Windows and Mac OS X.

The purpose of a file management application like Dolphin is to enable users to locate specific files and 
open, delete, copy or move them, among other tasks. Dolphin and other file management programs also 
allow you to organize your files by moving, copying, deleting or renaming entire folders. Keeping your files 
well organized helps you retain a logical layout that makes other processes easier and quicker to manage.

Help files and tooltips are accessible from within the Dolphin application, including the integrated Dolphin 
Handbook, found under the Help menu. Whilst the Handbook provides functional reference, this 
supplementary guide is aimed primarily at beginners and intermediate users, and starts by explaining things 
in basic terms before moving through to more advanced topics. Experienced users might nonetheless learn 
something new since Dolphin has so many configuration options, often subtly implemented or hidden away 
in dialogs. Many people find a way of working that makes sense to them and then stick with it, even though 
an alternative may exist that would be more logical, informative or efficient.

With this guide, you can gain an additional overview of practices and methodology, and many screenshots 
are included to provide a visual reference. These screenshots show several instances of Dolphin using 
different theming elements and configurations, to give you an idea of how the application may look under 
various setups.

Terminology used in this guide

Before continuing, it's worth noting a few naming conventions and substitute terms found in this document:

• Folder/Directory: These two terms are effectively the same thing. A folder on your system, be it 
empty or containing files, is also referred to as a directory. Both terms are used interchangeably. 
Similarly, a subfolder (a folder one level beneath another) is also known as a subdirectory.

• KDE/Plasma/Plasma Desktop: The desktop environment commonly referred to previously as KDE 
(e.g. KDE 3 or KDE 4), has undergone multiple renaming schemes in recent years. The term KDE 
now refers primarily to the KDE community of employees, volunteers and enthusiasts, including the 
developers of the various software components that provide users with an interface for interacting 
with their computer or device. This interface has three distinct major components: the KDE 
Frameworks, which provide the underlying code to build elements with; Plasma (usually referred to 
as the Plasma Desktop but also pertinent to other devices, e.g. Plasma Mobile), which provides the 
visual environment that users interact with; and finally the KDE Applications, the individual programs 
that are built to work with these technologies. Dolphin is one such KDE application.

• Right-click: when referring to right-clicking, for example with the right-click context menu, it is 
supposed that you are using a mouse or touchpad that is operating in right-handed mode.

• Root/Administrator: The root or super user on the system is commonly the administrator. Normally, 
only root has access to certain system files and functions, although some operating systems enable 
regular users to assume super user control without requiring additional login credentials.

• Trash/Wastebin: Depending on your system locale settings, some elements of the interface may be 
referred to differently. One notable example is the Trash, which is also known as the Wastebin. Users
of other operating systems might also think of it commonly as the Wastebasket or Recycle Bin.

• View/Workspace: The View component of the Dolphin interface is referred to in this document as 
the Workspace, to avoid confusion with multiple other references to the word view.
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Getting started

Installing Dolphin

You may already have Dolphin installed on your system, particularly if you are using the Plasma desktop 
environment, where it is generally provided as a standard component. If that's the case, you can skip this 
section.

Package installation is an entire topic in itself and the methods are too numerous to list here, but if Dolphin is
not already in the default software repositories of your distribution, you should try to obtain the version 
specifically packaged for your system. Refer to your Linux distribution or operating system's help pages for 
precise instructions on installing software packages. Most distributions provide some form of graphical 
package manager, in which you can simply search for Dolphin, select it for installation using the tools 
provided, then review and accept other dependencies and changes that are proposed. You may be required 
to enter the root (administrator) password.

For command line enthusiasts, here's a few example installation commands for popular Linux distributions:

Under Fedora (version 22 or later):
dnf -y install dolphin

For Red Hat/CentOS and earlier versions of Fedora still using yum, simply replace "dnf" in the above 
command with "yum".

Under SUSE/openSUSE:
zypper install dolphin

In Ubuntu, Debian and many other distributions using .deb packages, there are several possibilities:
sudo dpkg -i dolphin.deb
Using the apt-get command would be better: sudo apt-get install dolphin
Or better still, use Aptitude, with the command: sudo aptitude install dolphin

For Arch using the Pacman package manager:
pacman -S dolphin

Note that the first complete version of the newer Dolphin based on KDE Frameworks 5 was released with 
KDE Applications 15.08, that referring to the date of August 2015. Those distributions offering up-to-date live 
images, spins or a rolling release may provide the best way to try out the latest Dolphin version.
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Launching Dolphin

Dolphin can be launched in a number of ways, depending on your system environment and its configuration. 
If you have a Dolphin icon on your desktop or home screen, simply click on it (for desktop mouse or 
touchpad users, a single or double click may be necessary according to your setup).

For users of the Plasma Desktop, Dolphin will commonly be the default file management application, so you 
can click a Home folder icon or any other folder (directory) icon on your desktop to launch it.

Dolphin can also be launched from the main applications menu; it's often one of the default items in the 
Favorites tab in the Plasma Kickoff menu, or is usually classified under the System > File Manager category 
of other applications menus. Many distributions also include a Dolphin launch icon on the panel or taskbar.

If you are using the Plasma Desktop and intend to use Dolphin regularly, having opened Dolphin you can 
right-click on its entry in your Task Manager (the "taskbar" or panel containing buttons for opened programs),
then check the option to Show A Launcher When Not Running. This will place a Dolphin launch icon in the 
Task Manager, but it will only be visible when Dolphin is not already open, which helps to free up space for 
running application entries.
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Figure 1: The Plasma Kickoff menu in this example shows Dolphin listed under System in the Applications tab, whilst a launcher icon 
also appears next to the main menu button at the left of the bottom panel.



The Dolphin interface

Your own version of Dolphin might look a little different to the image in Figure 2, below. Aside from the 
window decorations and theming elements (colors, icons, borders, etc.) applied by your desktop or device 
environment, the application has undergone several evolutions during its lifetime, each one changing certain 
details incrementally. However, most of the fundamental concepts remain the same.

Users of right-to-left (RTL) language layouts should adapt the information in this guide accordingly. Where 
reference is made to an item or feature on the left-hand side, this might in such a circumstance refer instead 
to the right-hand side. Of course, not all aspects of the interface are simply mirrored in such a way, so this is 
not an absolute rule.

This default configuration is easy for beginners to understand, but Dolphin is highly configurable and its rich 
feature set can be made easily available to the most advanced users.

Like Konqueror, Dolphin can be used to browse through the file system and locate files and directories 
(folders). Files can be opened in various applications, deleted, moved to other locations, and copied. Unlike 
Konqueror, which can also be used as a web browser, Dolphin can only be used as a file manager.

Although Dolphin is not able to browse the web, access to remote resources is possible in other ways. For 
example, you could browse another system's files to which you have access via a local network or across 
the Internet. Functions like copying and moving files can be performed between different machines the same
as you do on your local machine.

All of this functionality is disguised behind the relatively simple interface you see when first launching the 
program.
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Figure 2: The default Dolphin window. It's easy for a beginner to understand, but can also be configured to suit the needs of an 
experienced user.
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Figure 3 indicates the main elements of the Dolphin interface, and this example shows two workspaces 
(views), but by default there's only one. Using two workspaces allows you to easily drag files from one to the 
other to move or copy them. Files and folders can also be moved or copied by dragging them from the 
workspace to a folder shown in the Places or Folders panels.

Menu bar and Control button

The Menu bar contains drop-down menus that allow access to all of Dolphin's features and functions. This 
includes things such as choosing which panels are displayed, configuring the toolbars to show additional 
buttons, and configuring the overall functions of Dolphin.

In many default configurations of Dolphin, this Menu bar has been removed and replaced by a Control button
on the Toolbar. See the two examples in Figure 4, below. When the Menu bar is not shown, click on this 
Control button and you will see an option, Show Menubar, at the bottom of the list, which you can click to add
the Menu bar to your window. To hide it, on the Menu bar click on Settings and deselect the Show Menubar 
option.

Another quicker way to toggle the show/hide status of the Menu bar is by using the key combination Ctrl+M 
(hold down the Control key and press the M key). Note that this key combination has the same effect in other
KDE applications, so if Dolphin isn't the active window, you might unwittingly toggle the Menu bar status of 
another program.
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Figure 3: The major components of the Dolphin interface. Note that this is a more complex configuration with some elements that are 
not part of the default configuration for Dolphin.



Dolphin, like many other KDE applications, often provides multiple ways to perform the same function, so 
that you can choose the method that makes most sense to you or which works best in a given situation. An 
example of this is the optional Toolbar button to Show Menubar, which provides another quick way to toggle 
the Menu bar on or off. For more details, refer to the list of Other Toolbar buttons under the section on 
Toolbar functionality.

Toolbar

The Toolbar is the row of icons and/or text buttons positioned by default at the top of the window, just under 
the Menu bar if that is set to visible. It provides ready access to many functions of Dolphin. You can configure
the Toolbar to contain the buttons for the functions you use most. This is explained in great detail later on.

Standard configurations of Dolphin often now include the Control button on this Toolbar (see Menu bar and 
Control button, above) giving access to most of the same options and parameters as the Menu bar but from 
a single drop-down list.

Location bar

The Location bar shows the path to the folder being viewed in the workspace beneath it. Note in Figure 5 
that there are two styles of Location bar that can be configured. Each workspace or tab can use whichever 
mode you choose without affecting the others.

• Editable location: This style of Location bar is a standard text entry field where you can type the 
complete path to a folder. It displays the path in command line interface style to the directory 
displayed in the workspace below.

• Breadcrumb view: In this mode, each folder in the path is displayed as a button. You can click on 
any folder button in the path to navigate immediately to that folder. Once you do so, however, the 
buttons for the deeper levels of the directory tree are no longer displayed. The deepest level of the 
tree shown is the one currently displayed in the workspace below. You can also click the arrow 
buttons between each folder level on the Location bar to view a drop-down list of other subfolders 
that can be reached from that point in the directory tree.

There is an easy way to switch between these two styles of Location bar. See Figure 5, below. When in 
Editable location mode, you will see a tick mark at the right-hand end of the bar. Hovering the mouse pointer 
over this symbol shows a tooltip with the text, "Click for Location Navigation", which will switch to the 
Breadcrumb view. Whilst there is no such symbol visible in Breadcrumb view, you can click in the same area 
to the right of the Location bar to change back to Editable mode. Hovering the mouse pointer here shows the
tooltip text, "Click to Edit Location".
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Figure 4: Two different configurations of Dolphin: older style with Menu bar (top); newer style with a Control button replacing the Menu 
bar (bottom). An intermediate style also existed showing a spanner icon to the right of the Toolbar.



The panels

The Places and Folders panels, arranged by default on the left side of the Dolphin window, allow you to 
navigate to various locations. The Information panel, by default on the right-hand side, provides further 
details on items you are viewing, whilst the Terminal panel at the bottom serves as a useful way to quickly 
access the command line, of most interest to advanced users. To show or hide any of these panels, on the 
Menu bar, click View > Panels, or click the Control button and go to Panels, where a submenu will provide 
the option to check or uncheck each one.

Although a default panel arrangement is proposed, when unlocked, these panels can be moved to other 
locations on the Dolphin window. From the Panels submenu mentioned above, select the entry Unlock 
Panels. Now grab the title bar of the panel you want to move and drag it to another location in the stack of 
panels, or move it to the opposite side of the Dolphin window. A visual guide indicates where the panel can 
be dropped as you move it around. In some versions of Dolphin, the panels can also be dragged out to the 
desktop and undocked from the Dolphin window completely.

Notice that the Folders and Places panels, by default, are stacked on the left-hand side one above another, 
like in Figure 3. Stacking the panels like this can allow you to use your valuable screen real estate more 
effectively. The dividers between each panel, and between panels and the workspace, can be dragged to 
apportion the spacing and set the relative sizes of each element, so you could, for example, give more 
vertical space to show the Folders panel whilst giving less to Places.

Clicking on the diamond icon, if it exists, undocks the panel and moves it out to the desktop. Clicking on the 
diamond icon while the panel is undocked re-docks it back into its previous location in the Dolphin window.

Any panel can be removed completely by clicking on the X button in the upper right corner on its title bar 
(when in unlocked mode). If you have set the panels just how you want them, or you wish to avoid 
accidentally dragging them to another position, on the Menu bar go to View > Panels or click the Control 
button > Panels, then select the Lock Panels entry. You will no longer see the crosses to close panels, but 
you will still be able to drag the dividers between them, or edit the items the panels contain.

Places panel

The Places panel is a configurable list of folders and other places such as permanent and removable drives 
to which you may need to navigate. To add a new place to this panel, simply drag the folder from a 
workspace to the location you want it in the Places panel. You can move items within this panel by dragging 
them up or down in the list.

The Places panel is not hierarchical. It is a single layer of places, typically those which you frequently 
access, a little like bookmarks in a web browser. To navigate to any of the folders in the Places panel, just 
click on one.

Entries in this panel can be edited by right-clicking and selecting an option from the pop-up context menu. 
You can elect to hide individual Places, show previously hidden ones, change the icon size or rename an 
entry. This latter option only changes the name as it appears in the Places panel, not the actual folder name. 
Some Places entries have specific options, such as Empty Wastebin, whilst other items show or hide 
automatically when media is inserted or removed.

If you are keen to save screen space or keep a minimal look to your Dolphin window, the Places panel can 
be closed without losing all of its functionality. When closed, an additional folder icon appears to the left of 
the Location bar. Click this, and you will see all your Places listed in a drop-down menu.
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Figure 5: The two styles of Location bar: Editable mode (top); Breadcrumb mode (bottom), with the relevant tooltips for switching mode.



For users of the Plasma Desktop, note that by default, the Places bookmarks you create within Dolphin will 
appear elsewhere on your system, although this behavior can be changed by editing an entry. For example, 
the same Places will show up in the default Kickoff main menu under the Computer category, or in file 
open/save dialogs. You might find it useful therefore to add entries for Places where you frequently open or 
save files, like your Documents folder.

Folders panel

The Folders panel is somewhat similar to the Places panel in that it allows you to navigate to folders 
displayed in it. This panel, however, is a complete directory tree of the entire file system. This tree cannot be 
changed, as it reflects the exact current state of the file system. What you can do with the Folders panel is 
click on a folder to display its contents in the active workspace. You can drag and drop folders and files from 
the active workspace to any folder displayed in the Folders panel to move them to that target folder. You can 
also drag and drop folders from one place in the Folders panel to another in order to move them.

The Folders panel does not display files. It only displays folders. Files are only displayed in the workspace. 
By right-clicking on a folder in the Folders panel, there is an option in the pop-up menu to Show Hidden Files,
although in fact this only shows hidden folders.

Information panel

The Information panel displays information about the currently selected file(s) or folder(s), or the file or folder 
over which the mouse pointer is hovering. If the file is a document or graphic of some type, Dolphin will try to 
display a preview of it. In Figure 3 you can see the preview of the PDF document that is selected in the right-
hand workspace. If Dolphin cannot display a preview of the file, it will display an icon representing the type of
file it is. Typically, less information is shown when multiple files are selected, because Dolphin can only show 
information that is common to all of them.

If you have the necessary codecs and plug-ins installed on the system, certain media files such as audio and
video can also be previewed in this panel by using the Play/Stop buttons and the time-seek slider alongside.

Other details that can be displayed in the Information panel include the size and type of the file as well as the
last time it was modified. You can change the information that is shown by right-clicking on the Information 
panel and selecting Configure.... The available options are dependent on the current file type that is selected.
So, for example, by first selecting a text document in the workspace, you will find options under Configure... 
to show the number of Lines or Words in the file, whilst for an image document there will be options for 
Height and Width. This enables you to fine-tune the information you want shown for many different file types.

Semantic information such as Tags, Comments and Ratings attached to files can also be displayed here, if 
your desktop environment has been configured to use these functions.

Terminal panel

Dolphin incorporates a very convenient terminal, providing a command line interface (CLI) which interacts 
with the rest of the file manager. When initiated, the prompt will be ready at the current folder location as 
shown in the active workspace, and by default the terminal will appear docked to the bottom of the Dolphin 
window, but you can also drag it to the top or detach it onto the desktop. A quick way to toggle this panel on 
or off is to use the F4 key on your keyboard.

Whilst not only being a practical tool for advanced Linux users and administrators, the Dolphin terminal 
provides a good CLI for novices to begin experimenting with, because you can switch back and forth 
between the graphical workspace and the terminal in just one application. As you navigate in one, the 
directory path is updated in the other.

For instance, whilst displaying your home directory in the workspace, click to navigate to a subfolder 
(subdirectory) named Pictures, and you will see the equivalent command for doing so reflected in the 
terminal (cd /home/{username}/Pictures). If you now type cd .. (that's the letters "cd" meaning 
"change directory", followed by a space and then two periods/full stops) in the terminal to navigate up one 
level in the directory tree, you will see the workspace above update, returning you to your home directory.
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Filter bar

The filter bar allows you to type in a name or file name extension and filter the display so that only files and 
folders whose names match the typed string of characters are displayed. You can also match just a part of 
file or folder names. For instance, if you type dev in the Filter bar, the workspace will display only those files 
which have the specific string "dev" somewhere in their names, e.g. a file named "Development.html" or an 
image named "reddevils.jpg".

To show the Filter bar, go to the Menu bar and click on Tools > Show Filter Bar, or click the Control button > 
Tools and select Show Filter Bar. The key combination Ctrl+I can be used as a shortcut to toggle the state 
of the Filter bar.

Figure 6 above shows the results of using the Filter bar in the left workspace. Other than the fact that a text 
string has been typed in the Filter bar, this is the same folder as seen previously in Figure 3.

By showing or hiding the Filter bar as explained above, its visibility status is only relevant to the current tab, 
window or Dolphin session. It is also possible to configure Dolphin so that the Filter bar is permanently 
displayed. Refer to Startup under the section Configuring Dolphin for details.

For those users willing to dive in deeper, an explanation about wildcards and regular expressions:

The Filter bar also accepts some wildcard characters such as the question mark (?) which denotes that any 
unspecified character can occupy a single place in the text string you type, in place of the question mark 
itself. Two question marks means any two unspecified characters. Another wildcard is the asterisk (*), which 
denotes a variable number of unspecified characters, including none at all. This provides the ability to make 
very precise yet flexible matches with a single matching string. Note that this string is not case-sensitive. 
When using wildcards in the Filter bar, surrounding wildcards are also required to match any number of 
unspecified characters either side of the string you type, including file extensions.

For example, typing the string d?v in the Filter bar will only show files and folders named exactly "Dav", 
"dav", "dev" or any other three-character term starting with "d" and ending with "v". It will not find terms such 
as "dev.txt" or "developer". To apply a filter to show all files with "d" and "v" separated by one character, but 
with this string anywhere within the name, you must place an asterisk either side, e.g. *d?v*. This would 
find additional files named "udev", "divided" and "developer", but not "driver", since this contains an 
additional character between the "d" and the "v". Using the asterisk and typing *d*v* would find all of the 
above terms, including "driver", "dev.txt" or simply "dv".

One other method you can use is to place characters between [square brackets]. For example, typing the 
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string d[ae]v filters only files named "dav" or "dev", but not "drv" or any other name in which "d" and "v" are 
separated by a single character besides the specified "a" or "e". The square brackets represent a single 
character place in the string, but the (in this case) two characters within the brackets represent the 
characters allowed in that position. So d[ae]v is a three-character string, but only "a" or "e" are allowed in 
the second position. Again, you need to place surrounding wildcards at one or both ends in order to show 
files with any additional characters before or after this string.

Earlier versions of Dolphin also supported certain regular expressions. An example can be seen in Figure 6, 
above, where the text string d.v has been typed to filter only files which have the characters "d" and "v" but 
separated by a single place which can be any character at all. The period (.) in the filter string represents 
any character, just like the question mark, yet in this example surrounding wildcards are not required.

Changes made in Dolphin mean that current versions do not accept the same regular expressions as before.
Only the question mark (?), asterisk (*) and items enclosed in [square brackets] remain functional.

Status bar

The Status bar is located at the bottom of each workspace. It displays information about the selected file(s) 
or folder(s). If no objects are selected, it contains information about the folder that is being viewed in the 
workspace. This includes the total number of files and folders contained in the folder being viewed and the 
total disk space used by the objects in the folder.

Other information that can be displayed on the Status bar includes a zoom slider for changing the size of file 
and folder icons in the workspace, and a gauge showing the amount of remaining space on the hard disk or 
other drive relevant to the active workspace. See the General > Status Bar heading under the section 
Configuring Dolphin for details.

Workspace (View)

Last but not least, we have the Workspace, the center of your interaction with Dolphin. Technically, the 
workspace area is known simply as the "View". Bear this in mind when using the menus and other features 
of the application, and you'll find that certain functions and working principles, e.g. "Split View", "View Mode" 
or "View Properties" will seem more logical. Other documentation including the official Dolphin Handbook 
refers to the Workspace as the View. However, since this term is rather generic and used in countless other 
ways throughout this document, the word Workspace is preferred here to avoid confusion.

The workspace displays the files in the folder you are viewing. You can have one or two workspaces within a 
Dolphin window. The default is one, but it is easy to add the second. On the Toolbar, locate and click on the 
"Split" button, which has an icon with a plus sign (+) on one side. This will add the second workspace.

Note that as a visual aid, the background color of the current, active workspace (the one you're working in), 
is different from the background color of the inactive workspace. To close the active workspace, on the 
Toolbar locate and click on the "Close" button, which has an icon with a minus sign (-) or a cross (x), as in 
the examples above. There is another visual aid here, whereby the minus or cross sign appears on either the
left or right side of the Close button icon, depending on the currently active workspace, showing you which 
side will be closed. The previously inactive workspace now fills the window and becomes the active 
workspace.
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Toolbar functionality

Like the toolbar for any application, the Dolphin Toolbar provides a focal point for easy access to features 
and functions. All of the functions that can be accessed using the Dolphin Toolbar can also be accessed 
using the menus in the Menu bar, or from the Control button menu. The Toolbar reduces the number of clicks
required to do so.

Toolbar configuration

The Dolphin Toolbar is shown by default at the top of the window, just under the Menu bar if you have that 
set to visible, or directly underneath the window title bar if not. It contains buttons with icons and/or text 
labels which provide ready access to many functions of Dolphin. You can configure the Toolbar to contain the
buttons for the functions you use most.

The Toolbar in Figure 8 above will probably not look the same as yours, as several buttons have been added
to this example that are not in the default configuration.

Adding buttons to the Toolbar is quite easy. Using the Menu bar choose Settings > Configure Toolbars..., or 
click the Control button, then Configure Toolbars... to bring up a window like that seen in Figure 9, below.

Simply drag the tools you want from the Available Actions side on the left to the Current Actions on the right. 
Drop them where you want them in the sequence. Once the items are on the right side, you can change their
position by dragging them up or down in the list. You can click on Apply to make the changes and keep this 
window open, or click on OK to apply the changes and close the window.

To remove a tool from the Toolbar, drag it from the Current Actions pane to anywhere in the Available Actions
pane and it will automatically be placed in the correct alphabetical order in the list.
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Figure 9: Drag tool buttons from the left pane to the right one to add them to the Toolbar.



The arrow buttons in the middle can also be used to move selected items from the left to the right pane, and 
vice-versa, or to change the order of the selected item in the Current Actions list. The Change Icons and 
Change Text buttons can be used to choose a different icon or a different text label, respectively, for the item 
that is selected under Current Actions. If you want to revert to the standard toolbar button selection before 
any changes were made (in this or previous sessions) click on the Defaults button.

Some useful tools that are not on the Toolbar by default are the following:

• The Up button, which along with the Back and Forward buttons, allows you to navigate the 
directory tree structure. The Up button always takes you to the next higher directory level, while 
the Back button takes you to the previously viewed directory. The Forward button takes you to the 
directory that you just left.

• The New Tab button adds a new tab to the workspace so that you can have more flexibility in the 
number of folders (directories) you can work with simultaneously. Note that you can drag a file or 
folder from the visible tab to the background tab ("LinuxBook" in Figure 10, below) and drop it 
there, in order to move or copy the object to the directory named on the background tab.

So, now you've chosen the buttons you find most useful, but perhaps you don't want your Toolbar along the 
top of the window. Dolphin lets you place it on one of the other edges.

Right-click on any one of the Toolbar buttons, and from the pop-up context menu, uncheck the option Lock 
Toolbar Positions. Depending on the widget style you are using on your desktop or device, you might notice 
a small grab handle that now appears to the far left of the Toolbar. Also, if you right-click again on the 
Toolbar, you'll now notice a new option category has appeared on the context menu: "Orientation".

If you hover the mouse pointer over this grab handle the cursor changes to the Move symbol. By clicking and
dragging this handle with the mouse, you can place the Toolbar on one of the other edges of the window. The
other elements resize dynamically and provide a visual guide to where you can drop the Toolbar. The same 
functionality is achieved by selecting an option from the Orientation submenu: Top, Left, Right or Bottom.

Having the Toolbar on the left or right is probably better when using either icons with no text labels, text 
labels with no icons, or icons with text labels positioned underneath.

See the Tips and Tricks section for further customization of the Toolbar buttons.
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Common Toolbar buttons

Figure 11 shows a Dolphin Toolbar that has been somewhat customized with additional buttons. Your 
Dolphin Toolbar will almost certainly look different from this one, in that as well as alternative icon themes or 
optional text labels, it will have either the default set of buttons or the ones you prefer if you have already 
modified it.

The buttons in the above example represent merely a selection to which you might find it useful to have 
ready access. Let's discuss each in order from left to right.

Create New

The Create New button allows you to create a new folder, text or HTML file, or a link to a device, application, 
file or folder. It creates this new object in the currently active directory, i.e. the active folder in the active 
workspace. Click and hold this button to display the context menu that provides these choices.

Delete

The Delete button permanently deletes any and all selected objects in the active workspace. In Figure 11, 
the "X" in the button is greyed out because nothing is selected. When a deletable object is selected, the "X" 
is red. Depending on your icon theme, the style of the icon and the effect used may vary. Simply select the 
files, links and folders you want to delete and click on this button.
Warning: Objects removed with the Delete button are permanently deleted. They cannot be recovered.

Folders

The Folders button is a toggle, that is, it toggles the Folders panel on and off. When clicked once, it causes 
the Folders panel to be displayed and the button remains depressed. When clicked again, the button is 
raised and the Folders panel disappears. Notice in Figure 11 that the button is depressed.

Navigation: Up, Back, and Forward

The Navigation buttons allow rapid navigation between certain folders. Clicking the Up button, which is not 
on the Toolbar by default, takes you to the next level up on the directory tree. Clicking the Back button takes 
you to the directory that was previously the active directory. If you click the Forward button after clicking the 
Back button, it takes you forward to the directory you just left.

Home

The Home button will always take you to the folder specified in the Dolphin configuration as the Home 
directory. See Startup under the section Configuring Dolphin for details of setting the desired location.

Reload

The Reload button forces Dolphin to reload the information for the folder currently displayed in the 
workspace, similar to the Refresh button in a web browser. Thus if a file has been added to the folder, 
deleted, or modified, the change can be forced to show up. Most of the time, changes are updated 
automatically because some underlying daemons (background processes) look at each folder and send 
update notifications to programs that are working in or monitoring those folders, such as Dolphin.
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New Tab

The New Tab button opens a new tab in the Dolphin workspace. See Figure 10 under the section on Toolbar 
configuration, above. This affords more flexibility in navigating and managing files. It is like tabbed browsing 
in a web browser. They both allow you to have multiple locations open simultaneously in only a single 
instance of the program.

Delete/Close Tab

The Close Tab button, known as Delete Tab in earlier iterations of Dolphin, allows you to close the currently 
active tab. Other tabs are left open. The same function can be performed by clicking the close button on the 
relevant tab itself. If there is only one remaining workspace tab, the tabs will no longer be displayed. It is not 
possible to close the last remaining tab, since Dolphin must always display something in the workspace.

New Window

The New Window button launches a new instance of Dolphin. It's possible to copy and move files and folders
from one Dolphin window to another. This is another flexibility option that gives you the ability to work in 
whatever way is comfortable for you.

Views

The three Views buttons are designed to display the contents of folders in different styles, again giving you 
the option of viewing things in a way that is most meaningful and useful for you in a particular situation.

As Dolphin has evolved, the available viewing modes have been changed, as has the order of these three 
buttons. In Figure 12 above, the three original buttons seen on the left represent the Icon, Details and 
Columns views, going from left to right. Unless you have an old installation of Dolphin, you likely have a 
slightly different set of buttons, like those seen on the right. These represent the Icon, Compact and Details 
views.

In either case, the leftmost of these three buttons remains unchanged and is always the Icon view. With this 
mode selected, your workspace will display folders and files as larger icons in left-to-right rows. When the 
rows of icons exceed the workspace area, you can scroll up and down to see the remainder. This is usually 
the default view mode when displaying a new folder. The left workspace in Figure 13 below shows the 
contents of a folder using the Icon view.

The Compact view provides a listing of folders and files using smaller default icons to save space, making it 
better suited for folders containing a large number of items. Folders and files are listed from top to bottom, 
and when reaching the bottom of the workspace, the list continues in a new column to the right-hand side, 
requiring you to scroll horizontally to see additional columns.

The Details view also provides a listing of folders and files with smaller icons, but in one continuous column 
which can be scrolled vertically. By default, each item's size and date is also shown alongside. You can 
configure this view to show additional columns of information such as the file type, permissions and 
ownership settings. Refer to Configuring columns in Details view mode, under the section Basic Tasks, for 
instructions on how to do this. The right-hand workspace in Figure 13 below shows the contents of a folder 
using the Details view. In this example, some of the additional columns of information are not visible because
the window is not wide enough, so the horizontal scroll bar can be used to see them.

The Columns view was provided in older versions of Dolphin and later removed. This was a mode familiar to 
some Mac users that spawned a new column for every directory level the user navigated through. This is not 
to be confused with the Split view explained below, which allows the contents of two folders to be displayed 
side-by-side.
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(right). Note that the middle and right-hand buttons in this comparison do not perform the same functions, as explained below.



Preview

The Preview button turns the preview feature on and off. Previews show the first page of a document or a 
small thumbnail view of a graphic. For folders, a preview of some of the files contained in the folder is 
overlaid on top, as a visual clue to the contents.

Having Previews enabled takes memory and CPU cycles, so it can be a drag on the performance of systems
with slow processors or small amounts of RAM. In such instances, you may want to disable previews. A 
configuration option allows you to set a file size limit for generating remote previews, i.e. files in locations that
are not on the host machine. To see previews of some file types, e.g. videos, PDF or office documents, you 
may need to install additional, optional packages on your host machine, and then check the relevant options 
in Dolphin's configuration dialog. See the General > Previews category under the section Configuring 
Dolphin for details.

Note that previews can be applied to all view modes, but when in the Compact or Details view modes, the 
default small icons and line listings may grow in size to enable the previews to be seen clearly.

Split/Close

The Split button is shown when there is a single workspace in a tab. Clicking on this button splits the 
workspace into two. Figures 3, 6, 10 and 13 above all show a split workspace. When the workspace is split, 
the Close button is displayed. Clicking on the Close button closes the active workspace. This is explained 
more fully in the section on The Dolphin interface, above, under the heading Workspace.

Zoom

The Zoom buttons (one for zoom in and one for zoom out) increase and decrease the size of the icons or 
previews in the active workspace. This is the same function as performed by the zoom slider at the bottom of
the right-hand workspace in Figure 13, above.
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Figure 14: The Dolphin Split and Close buttons as they may appear under two different themes: Oxygen (left); Breeze (right).



Configure Toolbar.../Configure Dolphin...

These buttons open the windows to configure the Toolbar and to configure Dolphin, respectively. Refer to the
relevant sections in this document on Toolbar configuration and Configuring Dolphin for further details.

Dolphin Handbook

This button opens the Dolphin Handbook, which is a very nice set of instructions for using Dolphin.

About Dolphin/About KDE

These two buttons open small windows with a little bit of information about Dolphin and KDE respectively. 
This may include the version number and the author(s) as well as some other tidbits, which can be useful 
reference when seeking help with the program or reporting bugs in the software.

Exit/Quit

Just what its name implies, this button exits from Dolphin and closes it. The exact name used for this function
may depend upon your locale settings or your version of Dolphin.

Other Toolbar buttons

There are several other buttons not mentioned in the list above that can be added to the Toolbar. A brief 
description of each follows, in alphabetical order.

Note: At the time of writing, the Comment, Rating and Tags buttons pertaining to the semantic desktop can 
present some issues. You may see two entries for each of these buttons in the Available Actions of the 
toolbar configuration dialog, but only one may function correctly. In other use cases, neither of the two 
function correctly, and they may be missing default icons (though you can add your own by clicking the 
Change Icon button). These bugs may be resolved with future updates of Dolphin and/or other KDE/Plasma 
components.

Activate Next/Previous Tab – Lets you switch to other open tabs to the right/left respectively. When you 
reach the last or first tab, the function cycles around to the tab at the other end.
Additional Information – Provides a drop-down menu of additional file information that can be shown in the 
active workspace, such as file Size, Date and Type. These are the same functions found normally under the 
Menu bar > View or from the Control button > View.
Adjust View Properties... – Provides a shortcut button to the collective view properties dialog, where 
several display parameters can be changed at once. This is the same dialog as activated normally from the 
Menu bar > View or the Control button menu.
Audio – Click and hold this button to select whether to show Artist, Album, Duration or Track information 
(requires file indexing features to be activated).
Comment – Adds file comments to the listings in the active workspace (requires semantic desktop features 
to be activated).
Compare Files – This function relies on the optional component Kompare (formerly known as Kdiff) to be 
installed on the system. Selecting two (text-based) files or two directories, then clicking this button, opens the
Kompare application ready to compare the differences between the selected items.
Configure Shortcuts... – A common menu item in many KDE applications, providing quick access to a 
dialog where you can edit the keyboard shortcuts used within Dolphin.
Copy – Shortcut to the Copy to clipboard function found normally under the Menu bar > Edit. You may find 
adding this button useful if you do not show the Menu bar, since the function is not included on the Control 
button menu.
Create Folder – Whilst this function is also available under the Create New... command, adding this button 
provides a more direct link to creating a new folder (directory).
Cut – Shortcut to the Cut clipboard function found normally under the Menu bar > Edit. You may find adding 
this button useful if you do not show the Menu bar, since the function is not included on the Control button 
menu.
Date – Simply adds the file/folder dates to the listings in the currently active workspace. This works 
regardless of file indexing features being activated, and applies to all View Modes. Clicking the button again 
toggles the information off.
Descending – Reverses the file and folder listing order. This order is ultimately still dependent on the criteria
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selected under the Sort By menu, so if sorted by Date, for example, clicking Descending will show newest 
files first instead of the oldest.
Document – Click and hold this button to select whether to show a document's Word Count or Line Count 
(requires file indexing features to be activated).
Editable Location – Provides a button which, when selected, switches the Location bar to Editable mode. 
Clicking the button again toggles back to Breadcrumb view mode.
Find – Invokes a search bar above the workspace with additional search filters to help you find files and 
folders across the system, as well as text strings within files. This works regardless of file indexing features 
being activated, except for the filters found by clicking the More Options button. For more details, see Using 
the Find function, under the section Basic tasks. Clicking the Find button a second time does not close the 
search bar, you instead need to click the close button to the left of the search bar.
Folders First – When selected, shows folders before file listings in the active workspace (default mode). 
Deselecting this button mixes folders with files, in which case the order of both is wholly determined by the 
criteria chosen under the Sort By menu.
Image – Click and hold this button to select whether to show Image Size and Orientation information 
(requires file indexing features to be activated).
Information – Toggles the Information panel on and off.
Invert Selection – All files currently selected in the active workspace will be deselected, and likewise, all 
those not selected will now become selected.
Move to Trash/Wastebin – Provides a shortcut button to send any selected file(s) or folder(s) to the 
Trash/Wastebin.
Name – Sorts the contents of the active workspace by Name, which is the default sort order setting.
Open in New Tab(s) – Your button may or may not use the plural form of Tabs – this is a cosmetic change 
seen in different versions of Dolphin. Either way, clicking this button achieves the same goal. If you have one 
or more folders selected in the active workspace, you can open them in separate tabs.
Open in New Window – By selecting a folder, you can click this button to open it in a separate new instance
of Dolphin. Unlike the Open in New Tab(s) feature above, you cannot open multiple directories in this way.
Open Terminal – Instead of activating the Terminal panel within Dolphin, this button opens a Terminal 
window as a separate application, with the command prompt ready at the directory location of the currently 
active workspace.
Other – Click and hold this button to select whether to show Other information for all files and folders in the 
currently active workspace. These are the same options as found under the Menu bar > View > Additional 
Information > Other. This works regardless of file indexing features being activated, and applies to all View 
Modes.
Panels – Provides a drop-down menu of the different panels that can be shown within the Dolphin window. 
These are the same Panels options found normally under the Menu bar > View or the Control button menu.
Paste Clipboard Contents... – Shortcut to the Paste function found normally under the Menu bar > Edit. 
You may find adding this button useful if you do not show the Menu bar, since the function is not included on 
the Control button menu. Note that you can paste items from the clipboard that are not files or folders. In this 
case, a new file will be created, and a dialog will appear asking you to provide a name for this file.
Places – Toggles the Places panel on and off.
Properties – Brings up a dialog showing the selected file or folder properties. If no item is selected, the 
properties of the folder currently being displayed in the active workspace will be shown. This is a shortcut to 
the same feature found under the Menu bar > File, or from the right-click context menu.
Rating – Adds file ratings to the listings in the active workspace (requires semantic desktop features to be 
activated).
Recently Closed Tabs – Provides a drop-down list of tabs you had open previously but have since closed, 
similar to the function found in many web browsers, and useful if you close a tab by mistake. Clicking one of 
these entries will reopen that location in a separate tab, rather than in the current tab.
Rename – Provides a shortcut to the Rename function found normally under the Menu bar > File. When 
multiple files or folders are selected in the workspace, a separate renaming dialog will be shown. When a 
single item is selected, the option to rename it inline or via a separate dialog will be dependent on your 
Dolphin preferences. Refer to General > Behavior under the section Configuring Dolphin for details.
Replace Location – Switches the Location bar to Editable Location mode, and also selects the location 
ready to be quickly edited or replaced by pasting from the clipboard. Note that this function is distinct from 
the Editable Location button mentioned above, in that it does not toggle the Location bar between the two 
modes. The Editable Location button does not highlight the location, but instead places the cursor at the end 
of the file path.
Report Bug... – This button provides a shortcut to the bug reporting wizard, normally accessible from the 
Menu bar > Help, or via the Control button > Help. A drop-down list in the resulting dialog allows you to select
not just Dolphin but other KDE applications and components, and then takes you directly to the KDE bug 
reporting page in your web browser.
Select All – Selects all files and/or folders in the currently active workspace. This is a shortcut to the same 
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feature found under the Menu bar > File, or from the Control button menu.
Select Remote Charset – Provides a drop-down list of character sets that you can select to be used by a 
remote network connection.
Show Filter Bar – This button does exactly as it suggests, and displays the Filter bar at the bottom of the 
currently active workspace. However, it does not act as a toggle. To close the Filter bar, you must click on its 
integrated close button.
Show Hidden Files – Toggles the visible status of hidden files (also known as "dot files", i.e. those beginning
with a dot) and hidden folders.
Show in Groups – Groups the files and folders in the currently active workspace according to the criteria set
under the Sort By menu. For example, the grouping will be based on the first character of the filename if 
sorted by Name, or into small/medium/big categories if sorted by Size. This is the same function found 
normally under the Menu bar > View, or from the Control button > View.
Show Menubar – Toggles the visibility of the Menu bar on and off.
Size – Simply adds the file/folder sizes to the listings in the currently active workspace. This works 
regardless of file indexing features being activated, and applies to all View Modes. Clicking the button again 
toggles the information off.
Sort By – Changes the order of items displayed in the currently active workspace according to different 
criteria. For example, sort by file date and time, in which case oldest files are shown first, or sort by owner to 
show files belonging to different users of the system in alphabetical order. These are the same functions 
found normally under the Menu bar > View or from the Control button menu.
Stop – Clicking this button stops the loading of directory contents in the active workspace. Normally, there 
should be little delay in displaying files and folders, but with some particularly large folders, or when showing 
remote network folders (for example, those residing on another machine that may be loading via the Internet)
this process can take time and/or consume system resources.
Switch Application Language – This is another feature common to many KDE applications, usually found 
via the Menu bar > Help, allowing you to change the language of the Dolphin interface. The available options
will be dependent upon what language packages are already installed on your system, and any changes 
made will require a restart of Dolphin.
Tags – Adds file tags to the listings in the active workspace (requires semantic desktop features to be 
activated).
Terminal – Toggles the Terminal panel on and off. Note that this function is different to the Open Terminal 
button detailed above, in that it uses the internal Dolphin Terminal panel rather than a separate application.
Type – Simply adds the file type (e.g. folder, PDF document or PNG image) to the listings in the currently 
active workspace. This works regardless of file indexing features being activated, and applies to all View 
Modes. Clicking the button again toggles the information off.
Undo – This button will undo the last action performed, or at least the last action that it is possible to reverse.
Not all actions can be undone. The name of the relevant action will be appended to the button title, e.g. 
"Undo: Rename".
Unlock/Lock Panels – Toggles the locked status of the different panels within the Dolphin window. When 
unlocked, you can rearrange or close elements such as the Information panel or Folders panel.
View Mode – The different views (Icons, Compact, Details) detailed under the Common Toolbar buttons 
section above can all be accessed here from a single button with a drop-down menu. This is a space saver if
you prefer not to have the three separate buttons; functionally they are the same.
What's This? – In theory, many or most elements of any application window or dialog should have 
contextual help information associated with them, viewable by first clicking either the optional Help (question 
mark) button on the title bar, or by clicking the What's This? button, whereupon hovering the mouse pointer 
over different elements changes the cursor icon status to indicate items that can be clicked on to show a help
tooltip. In practice, these help tips are often missing or incomplete, depending on the application. Their 
availability can also be dependent upon the language settings. If you cannot find contextual help via this 
method, refer to the Dolphin Handbook accessible from the Menu bar > Help.

Control

Unlike all the above optional buttons, the Control button, as highlighted in Figure 4, will be appended 
automatically to the end of your Toolbar if you do not have the Menu bar showing. This Control button gives 
access to most of the same commands found on the Menu bar, but via a single drop-down list, indicated by 
the downwards pointing arrow. The Menu bar and Control button are mutually exclusive – you can only show
one or the other.
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Configuring Dolphin

Dolphin is highly flexible and can be configured to meet almost any needs pertaining to file system navigation
and file management. The major aspects of configuring Dolphin include the buttons on the Toolbar, as 
explained earlier, the tools available in the user interface (UI), and how Dolphin acts in certain specific 
circumstances.

The Dolphin Preferences dialog (Menu bar > Settings > Configure Dolphin..., or Control > Configure 
Dolphin...) allows you to configure the basic look and behavior of Dolphin. Many of the preferences set here 
are shared and will also affect the file/web browser Konqueror, if you have that installed.

Startup

The Startup category provides configuration for the default folder that Dolphin is to display each time it is 
launched. The Documents folder in your home directory, or the home directory itself is a good place to start 
and one of these should be the default setting already.

You can also specify that Dolphin always starts in Split View with two workspaces instead of the default one.

The Editable Location bar allows you to edit the path displayed in the Location bar to move directly to a new 
folder to display. This essentially sets the standard text entry field showing the URI as default on any tab, 
window or new instance of Dolphin that you open, instead of using the breadcrumb view. In either case, you 
can also navigate using the various panels, the buttons on the Toolbar and the workspaces themselves.

If you elect to show the full path inside the Location bar, instead of the navigation beginning at your home 
directory or from the currently selected Places entry, you will see the full path from the root of the file system.
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In this instance, your home directory would likely appear as /home/{username}/ in the Editable view, or
/ > home > {username} in the Breadcrumb view.

Finally, there is an option to show the Filter bar by default. This will make it display permanently in any 
workspace, unless you click on its close button.

View Modes

The View Modes category allows you to define the visual characteristics of each of the three viewing modes. 
The primary attributes that can be changed are the fonts and their size, and the sizes of icons and document 
previews, including the maximum width and height of the accompanying text labels.

For the Details view mode, there is an additional option, Expandable folders. When checked, this shows 
expander symbols at the beginning of each directory listing, and a tree-like vertical guide beside all the files 
and folders in the workspace. Clicking these expander arrows enables you to open subfolders and see their 
contents, all the way down through as many levels of subfolders as exist, without needing to leave your 
current directory. Likewise, as you navigate to these subfolders, you can see up through all the levels of the 
tree to where you started.

Navigation

There are two common options within the Navigation category. One permits you to open archives as folders. 
This refers to common compressed file types such as .zip, .rar or .tar.gz. Normally these require a separate 
application such as Ark to open, extract and compress the files and their contents, but if you check this 
option, you can navigate through them like any other folder within Dolphin. Of course, since some of these 
compressed files can be large and hold huge quantities of files or data, this can also slow down navigation.

Another option is to open folders during drag operations. This provides a smart way to navigate through the 
file system whilst dragging any file(s) that you want to move, copy or provide a link to. During the drag 
operation, hover the mouse pointer over another folder and, after a short delay, it will open and your 
workspace will show its contents. You can continue to navigate like this until you reach the desired folder 
where you drop the file(s).
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In some versions of Dolphin, the Navigation category is also where you can pick between single-click or 
double-click operation. Under Plasma Desktop 5 and using newer versions of Dolphin, this functionality is 
now governed centrally by the System Settings, under the Input Devices > Mouse category. This makes 
sense and applies the settings system-wide, but note that changes made here won't affect a running 
instance of Dolphin until you close and restart the application.

To many users not overly familiar with KDE applications and the Plasma Desktop, single-clicking can at first 
seem strange and render file selection and manipulation difficult. However, there are some unique tools and 
well-considered functions to make it work. Once you learn how to avoid pitfalls like accidentally opening files 
instead of selecting them, and how to master operations such as multiple file selection with the mouse, going
back to a system requiring double-clicks can seem unwieldy and cumbersome. More on these techniques 
can be found in the section Basic Tasks. Critically, you should ensure the option to Show the selection 
marker is checked. This is described further down under the General > Behavior configuration category.

Services

The next category in the left column is Services. Here you'll see a list of items that can be selected to appear
in the contextual menu (often referred to as the right-click menu). Some services are provided directly by 
Dolphin, such as the Delete menu option (distinct from the Move to Wastebin function). Other services are 
provided by additional applications that you have installed. If you are running Dolphin on the Plasma 
Desktop, you will likely see many services related to other KDE applications, such as the aforementioned Ark
compression tool, the K3B disc burner, or the image viewer, Gwenview.

If that's not enough, the Download New Services... button connects to the Dolphin add-ons online repository, 
where you can browse and install a wealth of specialist services to perform directly within Dolphin, expanding
its functionality much further.

Wastebin (Trash)

Under the Trash or Wastebin preferences, the range of options shown will depend upon the configuration of 
your system. For a regular user on a typical setup, a single wastebin will amass items from across the user's 
home directory, in which case all the preferences shown here are applicable to that one wastebin. For 
storage areas that are not accessible to the user, such as directories under the root file system or the home 
directories of other users, independent wastebins are functional and accessible only to those specific users.

If you have multiple data partitions, attached drives or other storage devices, you might see a list here of 
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locations that have their own separate wastebin attributed to them. Select one of the locations in the list, and 
then set the options below which apply to it. Each can have its own independent settings.

Dolphin can automatically delete any files in the wastebin that are older than a certain number of days, and 
you can set a maximum size for the wastebin, as a percentage of the space reserved on the disk on which it 
resides. The actual size in bits is shown alongside. If you worry about accidentally throwing out files that you 
might want to reclaim from the wastebin, set this to a higher limit. When the limit is reached, you have a set 
of options for how Dolphin will respond.

If you just want to be warned when approaching the limit, you will then need to manually intervene and 
remove or restore items in the wastebin in order to free up space. Alternatively, you can let Dolphin 
automatically delete the oldest files or the files with the biggest size (in bytes). This will occur on an ongoing 
basis, in which case no manual intervention is required.

General

Finally, the General category is full of configuration options sorted into tabs. Note that under some older 
versions of Dolphin, these General options were found within the View Modes category.

Behavior

Under the Behavior tab, you can specify whether all folders are to use the same viewing properties, which is 
useful if you have one preferred visual style. The other option remembers a specific set of properties for each
folder that you change from the defaults. For example, you may want your main home directory displayed 
using the default Icons view, but a directory filled with many files to be displayed in Details mode, and those 
containing many images to show previews. These settings can be retained for every time you navigate to 
these folders.

The following option to show tooltips can be a very useful addition. This does not refer to the regular tooltips 
you find when hovering over toolbar or title bar buttons, but to large overlays that appear when you hover the
mouse pointer over files and folders within the main workspace area. These tooltips can show all sorts of 
information, including large-size previews of the file or the folder contents. Some of these details are a 
duplicate of what can be displayed in the Information panel.
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The next preference is very important for mouse and touchpad users, particularly when choosing single-click 
operation as described earlier under the Navigation category. If you check the box to Show a selection 
marker, whenever you hover the mouse pointer over files or folders in the workspace, a + or – sign will 
appear in the corner of the item. In Figure 19 above, you can see the + sign in the top-left corner of the 
highlighted image file.

Click on these + and – symbols to select or deselect, respectively, one or multiple items. This applies in all 
view modes, and enables you to make selections without accidentally opening the files. Without this function,
when in single-click mode you will need to rely on the keyboard or use the keyboard in conjunction with the 
mouse/touchpad to make such selections.

If you enable natural sorting of items, there are some subtle differences in the order in which Dolphin lists 
files and folders. Let's imagine you have a folder containing an album of music files, each beginning with the 
track number. In regular alphanumeric sorting of files – that is from 0 to 9 and from A to Z – track 1 will be 
followed by track 10 in the list, rather than by track 2. Obviously this seems illogical to a human and is not 
necessarily what we want. Using natural sorting will attempt to remedy common disparities between what a 
computer and a human consider to be a normal order.

The last item under Behavior provides a possibility to rename items inline. With this option checked, when 
you rename a single file or folder in the workspace its filename will become directly editable as highlighted 
text, and the cursor will appear within. When the option is unchecked, renaming a file brings up a dialog box 
where you can make the changes. Note that the dialog box is always shown when renaming multiple files 
together.

Previews

This tab contains a scrollbox listing various file types or categories of file types for which previews can be 
shown. There are a few standard components, but items available in this list will be in part governed by 
additional dependent files and add-ons that you have installed on your host machine. Whilst JPEG Images 
might have their own listing with an additional configuration tool button beside, other common Images (GIF, 
PNG, BMP, ...) are grouped together.
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Some of the most common non-default file types that users often seek previews for are ODF (Open 
Document Format) office files, PDF and video files. If these thumbnail tools are not installed by default on 
your system, you will need to find and install the relevant plug-ins. In some cases, such as with video files, 
there is more than one solution that exists. Two example video preview plug-ins are the "mplayer" thumbnails
and the "ffmpeg" thumbnails. You may prefer the look and functionality of one or the other.

The option to skip previews for remote files above a defined size limit helps avoid delays in seeking preview 
data to extract from large files over a network.

Confirmations

This tab lets you configure whether confirmation dialogs will be shown when you move items to the 
trash/wastebin or delete them directly, as well as when closing an instance of Dolphin with multiple tabs 
open. Bear in mind that deleting a file bypasses the trash/wastebin and removes it for good, whilst items sent
to the trash/wastebin may be able to be retrieved, if the time or size limit hasn't been exceeded (see the 
Wastebin (Trash) category, above). In a typical setup, you might elect to freely send items to the 
trash/wastebin but require a confirmation before deleting files.

Status Bar

The last tab in Dolphin's configuration options affects the Status Bar as seen at the bottom of each 
workspace. By default, this shows the number and size of any items selected in the workspace above, or the 
number and size of all items if no selections are made. The two options here allow you to show a zoom slider
for changing the size of the items in the workspace, and to show the remaining space information for the 
drive on which the files in the workspace reside. This can also be quickly configured by right-clicking on the 
Status Bar itself.

For all of Dolphin's configuration options, you can press the Defaults button to return the settings to their 
original state, and you must press the OK or Apply buttons to effect the changes you have made.
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Basic tasks

Navigating the file system with Dolphin

The term "navigating the file system" is a fancy way of saying that you are moving from one folder (directory) 
to another to locate and manage files or other folders.

Some basic navigation commands can be found by clicking Go on the Menu bar, or from the Control button 
on the Toolbar. Here you'll find options to navigate Back, Forward, Up one directory or to your Home folder. 
You may already have shortcut buttons for some of these functions on your Toolbar. An additional item in this
menu is a list of Recently Closed Tabs, similar to the feature often found in web browsers. Clicking one of 
these reopens the location shown.

Using Dolphin to navigate the file system is quite easy. The Dolphin interface contains a number of elements 
directly related to the process of file system navigation and locating files you need to find so that you can 
work with them:

1. Location bar
2. Places panel
3. Folders panel
4. Filter bar
5. Workspace (View)

Displaying files

There are a number of options for how the files are displayed in the workspace. The default View mode is 
Icons, where you simply see the icons of the objects and their names. The difference between the Icon view 
and the Compact view is that the Compact view lines up the icons in neat columns that you can scroll 
through horizontally. The Details view by default shows more information about the files and folders, such as 
their size, when they were last modified and who the owner is.

Refer to the Views category under the section Common Toolbar buttons for more explanations of the 
differences between these modes.

All view modes can be configured to show additional details for the files and folders in the workspace, but the
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Details view includes a few by default. Using this view could tell you, for example, that the reason you cannot
edit a file is that it does not belong to you and the permissions are set to disallow anyone but the owner of 
that file from changing it. Only the owner of the file or the root user can change the permissions of a file. On 
some systems, users in the same group may also have these privileges.

A short overview of File ownership and permissions settings in Dolphin can be found towards the end of this 
Basic Tasks section.

You can choose from among these viewing options using the Menu bar (if activated) or the buttons on the 
Toolbar. To use the Menu bar, select View > View Mode and then Icons, Compact or Details.

Showing additional information

Whilst the Details view mode provides more information at first glance, it's possible to configure the Icons or 
Compact view modes to show more than just the file or folder name. To do this, go to the Menu bar > View > 
Additional Information, or click the Control button then go to Additional Information, and check the items you 
wish to show. This can include the file Date, Type, Permissions, Owner and User Group. If any items are 
greyed out, it may be that you need the semantic desktop or file indexing features to be enabled.

Sorting files

Files are usually sorted by Name, in alphanumeric order. This is the default setting, but it can be changed. 
Go to the Menu bar > View > Sort By, or click the Control button and go to Sort By, then select the criteria by 
which you want your files to be ordered. The same options are available here as in the Additional 
Information, above, the difference being that you can only select one option for sorting by.

A couple of extra checkboxes appear at the end of the list. Selecting the option Descending will reverse the 
order, whilst unchecking Folders First will mix both folders and files together and sort all items purely by the 
criteria you have chosen.

Configuring columns in Details view mode

Unlike the Icons and Compact view modes, when in Details mode, a row of column headings occupies the 
top of the workspace, underneath the Location bar. You can see this in Figure 21 above. The column 
headings are configurable in a number of ways.

Firstly, you can click on one of these headings to sort all the files in the workspace below by that particular 
criteria. This is just a more direct way of achieving the effect already mentioned in the above section on 
sorting files, with the default sort method being by Name, in alphanumeric order top to bottom. Clicking this 
heading alternates the order to instead sort from bottom to top. You will note the indicator on the column 
heading changes to reflect this order.

Similarly, if you click on the Date heading, the files will be sorted chronologically by last modified date/time, 
oldest at the top, but clicking the heading a second time will flip the order to show newest at the top. This is a
convenient way to find recently modified files within a directory.
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The scope of details shown for each file or folder can be modified. Right-click somewhere on the row 
containing the column headings (Figure 22, above), and you will be presented with a context menu showing 
all columns that can be added or removed. Check the box next to each column of Additional Information you 
want to be visible. Some details such as Ratings are dependent upon semantic desktop functions being 
enabled; others such as Document Word Count require the desktop's indexing tools to be enabled and 
running. Under the Other submenu, you will find options for file Owner, Group and Permissions, which is 
particularly useful for administrators.

Another option here allows you to choose between Automatic or Custom Column Widths. It is also possible 
to manually drag the small dividers between each column in the headings row. The columns can be 
rearranged by clicking and then dragging a column title to the desired location, however the Name column is 
always shown first, i.e. furthest to the left.

Show in Groups

A lesser known function in the View options is Show in Groups. Find it on the Menu bar > View, or click the 
Control button on the Toolbar, whereupon it appears on the drop-down menu. When checked, the contents of
the folder displayed in the workspace are divided into groups based on the current sorting criteria. By default,
this will be the Name, so a category will now be displayed for the first letter of each item in the folder. Only 
those letters, numbers or symbols for which there is at least one file or folder beginning with that character in 
the currently displayed directory will have a group created. Hence, if there are no files beginning with X or Z, 
the grouping will run from A to W, with one more group for Y. As with the regular, ungrouped view, folders are 
shown first by default.

The functionality goes beyond just grouping items by letters of the alphabet and/or numbers and symbols. 
There are some interesting ways to break down your folder listings, but the easiest and most effective 
method of discovering these is to use the Details view mode. Refer to the section on Configuring columns in 
Details view mode, above, and change the sorting of items by clicking on one of the column headings.
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Now, the Show in Groups function gets interesting. If you sort by Size, for example, the Folders are shown 
first in ascending order of the number of items they contain. Underneath, files are grouped into Small, 
Medium and Big. Sort instead by Date (as in Figure 23, above), and items are grouped into chronological 
categories, starting with the month/year and then leading up to more precise grouping for recent days and 
weeks, again with folders shown first. If you add the Type option to your column headings and sort by it, you 
can now group items by file type, e.g. folder, ODT document, PDF document, WebM video, etc. Adding the 
Owner column heading and then sorting by this criteria groups files by owner – another very useful tool for 
system administrators.

Switching to Icons or Compact view mode retains the grouping until you uncheck the Show in Groups option,
but in order to change the sorting method, you will need to go to the Menu bar > View > Sort By, or click the 
Control button on the Toolbar, and go to Sort By.

Hidden files

When you first install and start using Dolphin, by default it will not show your hidden files and folders. On 
Linux and Unix systems, any file or folder whose name begins with a dot (.) is referred to as a "dot file", and 
considered "hidden". These are most commonly configuration files which are hidden this way for two good 
reasons. Firstly, because if a user moves, edits or deletes such files or folders this can cause system 
problems and instability. Secondly, since these files and folders can be numerous and most users won't need
to deal with them very often, keeping them hidden avoids clutter and confusion when you look at your home 
directory and its contents.

Note that hiding files this way to avoid others finding them offers very weak security; it is not difficult to 
discover such files, and that is not the use for which they are intended. Keeping files and data safe from 
prying eyes is achieved via alternative methods and concepts, such as multiple user logins, password 
protection, encryption and other good security practices. Whilst tools can be used within Dolphin to assist 
with such processes as encryption and decryption, these techniques are not a primary focus of the 
application.
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To view hidden files and folders in your Dolphin workspace, simply go to the Menu bar > View and check 
Show Hidden Files, or click the Control button, then Show Hidden Files. Do the same again to hide these 
items. The key combination Alt+. (Alt plus the period/full stop) can be used to toggle between the shown 
and hidden states.

Adjusting view properties collectively

The majority of the viewing options already outlined above can all be configured together from one dialog. 
On the Menu bar, click on View > Adjust View Properties..., or find the same function from the Control button 
on the Toolbar. The view mode, previews, sorting, grouping, hidden files and additional information can all be
configured here. The options at the bottom control whether these settings affect the currently displayed 
folder, the current folder plus all of its subfolders, or all folders on the system.

The last checkbox will set these view properties as the default for all folders you open thereafter. This 
standardizes the viewing mode system-wide (for the current user), but it applies in a forward sense meaning 
you should not lose any custom configurations you have already applied to other folders.

Many of the view parameters you set within Dolphin will also be shared and applied by other KDE 
applications such as Konqueror.

Using the Wastebin

The Wastebin (or Trash) can be viewed like other folders in the workspace, but with a few quirks that deserve
a special mention.

It should be reaffirmed that there is a difference between the action Move to Wastebin, and the Delete action.
The former moves the files temporarily to the Wastebin, a special location which has particular behavioral 
attributes, whilst deleting a file removes it for good; it cannot then be recovered.

In a default installation of Dolphin, the Wastebin appears amongst the Places. You can click on its entry in 
the Places panel to display its contents in the workspace. (The actual location of the default Wastebin is in a 
hidden configuration folder, usually /.local/share/Trash in the user's home directory on a Linux 
system, or in a hidden folder named something like .Trash-1000 – where 1000 represents the user ID of 
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the owner – in the root directory of any attached storage device, but you shouldn't need to worry about that).

Looking at the contents of your wastebin, some entries such as folders will display their size as Unknown. 
Another peculiarity is that unlike elsewhere on your system, the wastebin can contain multiple folders with an
identical name and/or identical contents. However, if two or more identically named files that are not 
contained within a folder are moved to the wastebin, even if they contain different content, at least one will be
automatically renamed and appended with a number to avoid confusion.

If you invoke the context menu by right-clicking any selected file(s) or folder(s) in the workspace, you will be 
presented with a more limited set of options than files in regular directories. The first of these options is 
Restore. Clicking this will restore the file(s) or folder(s) to the original location it was removed from. If any 
item has been renamed automatically because of duplicates in the wastebin, you may need to locate the 
restored file and verify its name, in case any document, application or system process depends upon it.

The second context menu option is Delete. This permanently deletes and removes the item(s) from the 
wastebin. Thirdly, there is the option Properties. Clicking this will open a dialog showing general information 
about the file(s), along with ownership and permissions settings. If the size is not shown, click on Calculate. 
In the case of very large items, this can take some time, so a Stop button is also provided.

Finally, by right-clicking on either the Wastebin icon under Places or in a blank area of the workspace whilst 
displaying its contents, an entry named Empty Wastebin will be shown in the context menu. This will 
permanently delete the entire wastebin contents.

For more information about managing the Wastebin and setting its storage parameters, see the relevant 
Wastebin (Trash) entry under the section Configuring Dolphin.

Removable Devices

The Devices category on the Places panel shows entries for removable media such as optical discs, USB or 
Bluetooth® storage devices, digital cameras, media players or mobile phones. In some cases, separate 
entries are created for the device's integral storage and any inserted storage medium such as a memory 
card. These Places entries appear and disappear automatically as hardware is attached or detached.

Access to these devices can be governed by many things: the operating system, desktop environment, 
permissions settings, etc. If you have the correct permissions, you can click these entries to open the device 
and show its contents in the workspace. This automatically mounts (registers as accessible) the device 
where necessary.

In Figures 19, 20, 29, 31 and 33, you can see an example of two attached devices labeled "transfer" and 
"shared". These are in fact separate partitions on the same external hard drive. The former is unmounted 
whilst the latter is mounted, indicated by the small status overlay in the bottom-right corner of the icon.

With many such devices, it is important to unmount them from the system before detaching the hardware 
physically. You can do this in Dolphin by right-clicking the relevant entry in the Places panel, and from the 
pop-up context menu, select Safely Remove {device name}. It is a good idea to first close any other Dolphin 
windows or tabs that are referencing the device, and configure other applications that are accessing it.

In some instances, Dolphin may not be able to unmount the device. This could be because it was mounted 
by another user, or it is still in use in another application. Try to resolve these issues before detaching the 
device physically, else data loss or corruption may occur. Contact the system administrator if necessary, or 
consider closing the window and opening a new instance of Dolphin in Super User Mode (see Expanding 
Dolphin Functionality at the end of this document), where you may be able to force the device to unmount.

Selecting files

Having covered all aspects of displaying files, the next logical step is to select some of them so as to perform
various actions, many of which will be described in the following sections.

Starting with the simplest scenario of selecting a single file, this is very straightforward, although for 
mouse/touchpad users, the method does vary depending on whether you are using single-click or double-
click operation (refer to Navigation under the section Configuring Dolphin).
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In double-click mode, you only need to click once on a file or folder to select it. If you then click on the item a 
second time (after a delay, not in the manner of a rapid double click), or click in a blank area of the 
workspace, the file is deselected. Clicking once on another file selects that file in place of the previous one.

In single-click mode, you should first enable the Show selection marker function by going to the Menu bar or 
Control button, then Configure Dolphin. Click the General category on the left, then the Behavior tab, and 
check this function. Thereafter, a plus (+) or minus (–) sign will appear overlaid on one corner of any item in 
the workspace when you hover the mouse pointer above. Click on this + or – symbol to select or deselect, 
respectively, the item. If you click elsewhere on the icon or its filename, you will instead open or execute the 
file/folder, which is obviously not what you want to do in this case.

Alternatively, when in single-click mode, regardless of whether you use selection markers, you can always 
hold down the Ctrl key and then click a file/folder to select or deselect it without opening or executing it.

You can also select multiple files to open, move, copy, delete or perform other actions on. There is no need 
to do those things one file at a time. Methods exist to achieve these actions using the keyboard, mouse, or a 
combination of both.

To select all files in the folder shown in the workspace, use the command Select All, which can be found by 
going to the Menu bar > Edit, or directly from the menu under the Control button on the Toolbar. The common
keyboard combination Ctrl+A works in Dolphin too for this purpose.

To select several files in a sequence, click on the first of these files in the workspace, then hold down the 
Shift key and click on the last file. All of the files in between will also be selected; then you can perform the 
same operation on all of them. Again, in single-click mode you need to click the + symbol on the first item to 
avoid opening or executing it.

In order to select a number of files that are not contiguous in the list, select the first file, then hold down the 
Ctrl key and click individually on the additional files you want to manipulate. In single-click mode, again use
the + symbol on each of the files to make your selections. This avoids needing to use the Ctrl key.

Once you have released the Shift or Ctrl key, clicking any one of the previously selected files deselects all 
the others. To deselect items individually, click the – symbol on the files or hold down the Ctrl key and click 
on the relevant selected items.

In conjunction with these selection methods, you can make use of the Invert Selection function, which is 
found via the Menu bar > Edit or under the Control button on the Toolbar. The key combination 
Ctrl+Shift+A can also be used. This turns all selected files into unselected files, and vice-versa. This is 
useful if, for example, you want to select most of the files with a few exceptions. Rather than meticulously 
select the majority one by one, you may find it easier to select those exceptions instead, and then simply 
invert the selection.

Selecting files with the keyboard

Users who prefer navigating with the keyboard instead of the mouse will probably already understand 
common techniques for manipulating files in other applications, most of which can also be applied to Dolphin.
All users can benefit from learning some of these techniques, as it can sometimes be faster and more 
efficient to keep the hands on the keyboard.

The possible keys that can be used and the functions performed are extensive, but a few keys in particular 
perform the majority of these functions. They are:

• The arrow keys (left, right, up, down)
• Home and End
• Shift and Ctrl
• The Menu key (the one with a list icon usually found beside the right Ctrl key; not on all keyboards)
• Enter and Escape
• The Space and Tab keys

The Shift key is the most important one when it comes to selections. Below is a quick practice routine. Open 
a directory containing several files in your workspace, click a blank area in this workspace to make sure it is 
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the active element in the Dolphin window, and then experiment with a few of these actions:

• Press the Home key. The first file or folder in the directory should now be highlighted for selection.
• Press the End key, and the selection now switches to the last item in the directory.
• Use the arrow keys to move the selection to other items, left, right, up or down.
• Now hold down the Shift key whilst using these arrow keys, and notice the files or folders in the 

direction you move to will become selected. In the Icons or Compact view modes, entire vertical or 
horizontal lines of files and folders can be selected this way using the arrow keys.

• Release the Shift key, press Escape and everything will be deselected.
• Press Home again to select the first item, then hold down Shift and press End to select all items.
• Finally, press the Menu key and the context menu will pop up, from where you can choose a 

command to apply to the selected items. You can continue to use the arrow keys to navigate this 
menu, and press Enter to apply the highlighted action, or Escape to exit the menu.

The key combination Ctrl+Space toggles the selection state of the current item(s).

The Tab key is used to navigate around the different elements of the Dolphin window, so that you can 
perform actions using the Menu bar, Toolbar and the various Panels.

Certain elements of the Dolphin interface, e.g. Menu bar items or tab titles, display an underlined character 
(provided that your desktop environment is configured to use this functionality). Hold down the Alt key and 
press the underlined character in order to activate the relevant function. The underlined character is not 
case-sensitive; you should not need to use the Shift or Caps lock key. For example, on a standard English 
installation with the Menu bar visible, the key combination Alt+h will display the Help menu. Subsequent 
selections from the same menu and any of its submenus do not require the Alt key, you can just type the 
underlined character. So whilst the Help menu is showing, pressing a will select the About Dolphin 
command. You can also use the arrow keys to navigate the menus, then press Enter to apply the 
highlighted action or Escape to exit.

Other key combinations can be viewed or changed by going to the Menu bar > Settings > Configure 
Shortcuts..., or clicking the Control button > Configure Shortcuts....

Another convenient way to select a file or folder with the keyboard is simply to begin typing the first few 
characters of its name. The selection will jump to the first matching item in the active workspace. This aids 
greatly in picking out a known file or folder in a long directory list without having to scroll and locate it visually.

Note that if you wait more than one second before typing each character of a file or folder name, the 
selection matching will reset. In a directory containing many similarly named files, the more characters you 
type in rapid succession, the more close a match will result.

Multiple file selection with the mouse

In addition to the methods detailed above using the + and – selection markers, a technique known as rubber 
band selection is effective for lassoing a range or zone of files and/or folders using the mouse or touchpad.

It can be initiated by clicking and holding down the mouse button when the pointer is in a blank area of the 
workspace. As you begin dragging in any direction, Dolphin will display an expanding rectangular box. When 
you have covered all the files or folders you wish to select, release the mouse button and these files will be 
highlighted. If some of the files are not in the visible portion of the workspace, Dolphin will scroll intelligently 
as you drag the selection box towards the edges.

In the Icons or Compact view modes (as seen in Figure 25, below), this type of rubber band selection 
enables you to select ranges of files that are not necessarily in alphanumeric order. You can drag across any 
number of rows, columns or both. Be sure to click and begin dragging from an empty part of the workspace, 
that is a blank area in between the icons and text labels, else you will drag the files instead.
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Sometimes you will find the most effective way to make multiple file selections is to use a combination of the 
above methods consecutively. When you've made one selection, you can still add or remove files via another
method before performing an action on those files.

Note that touch screen input is not covered in this guide since it is an evolving technology, and can currently 
produce somewhat inconsistent results depending on hardware and software configurations. Many 
applications are still in the process of implementing touch input, so its functionality is liable to undergo some 
degree of change.

Moving and copying files

After having selected one or more files, you can move or copy them to other locations (folders). Simply 
locate the target directory, i.e. the folder to which you want to move or copy the files. You can use either the 
Folder Panel, the Places panel, or the second workspace, in addition to other tabs or Dolphin windows. Then
drag the selected files to the new folder and drop them. A pop-up menu appears and you have to select 
whether you want to move or copy the files; select move or copy and the operation proceeds. You can also 
choose to cancel the operation.

Note that by holding down the Shift key during this operation, files will automatically be moved rather than 
copied, and no prompt will appear when dropping in the new location.

To copy from one Dolphin window to another, whilst dragging the files you may first need to hover the mouse 
pointer over the destination window's entry in your Task Manager ("taskbar" or panel) in order to activate it 
and make dropping files inside that window possible.

There is a fourth option in the pop-up menu when dropping files, which is to create a link in the target folder 
to the original file. This means you only have one copy of the file but the link in the target directory allows you
to manipulate it just as if it were actually in that directory. This allows you to have the same file available in 
multiple folders, but not have to worry about keeping them all up to date when you change it.
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(rubber band). Notice how the shorter name of the first item at the top left results in this folder not yet falling under the selection zone.



Standard keyboard shortcuts apply to these actions: Cut (Ctrl+X), Copy (Ctrl+C) and Paste (Ctrl+V).

Another method to copy or move selected files is by using the dedicated functions on the right-click context 
menu. This feature depends on the optional "Copy To" and "Move To" commands being checked in your 
Dolphin preferences. See the Services category under the section Configuring Dolphin for details.

These two entries, Copy To and Move To, let you navigate through your folders using a series of fly-out 
submenus. When you reach the desired target folder, click the Copy Here or Move Here entry at the top of 
the list. Within the first level of these multiple submenus there is also a "Browse..." option, which will open a 
file selection dialog. Navigate to the target directory in this dialog, and click OK.

Renaming files

Dolphin offers a few ways to rename files and/or folders. Having selected a file or folder, perhaps the easiest 
way is simply to press the F2 key on your keyboard. The same functionality is accessed via the Menu bar > 
File > Rename..., or from the right-click context menu > Rename....

In either case, the portion of the filename without the extension will be selected ready to be overwritten. 
According to your Dolphin preferences, as detailed earlier, you can rename items inline or via a separate 
dialog box. Refer to the General > Behavior category under the section Configuring Dolphin.

It is possible to select multiple files or folders for renaming together. In this case, the separate dialog box is 
always shown, and Dolphin proposes to rename the items with a common name terminating with an 
ascending number, represented by the hash symbol (#). Let's say you have three images, named

• Dsc00467.jpg
• Dsc00468.jpg
• Dsc00531.jpg

Enter "Picture#" in the rename box (without the quotes), and these images will now adopt the names
• Picture1.jpg
• Picture2.jpg
• Picture3.jpg

The starting integer can be modified to a higher number or a zero. The hash symbol is obligatory but it can 
be placed anywhere in the text string. To add leading zeros, add another hash. So typing "##_August" in 
the rename box and setting a starting value of 0, will result in the three files above being renamed

• 00_August.jpg
• 01_August.jpg
• 02_August.jpg

There is one exceptional case where the hash symbol is not required. If all of the files you wish to rename 
are of different types and hence have different extensions, you can enter a name with no hash symbol, and 
each of the files will adopt this same new name whilst retaining its original extension.

If you want more advanced batch renaming capabilities, there is a KDE application called KRename which 
provides a huge range of features. It can be used standalone but also integrates into Dolphin's right-click 
Actions submenu.
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Undoing actions

If you make a mistake when performing an action on files, many of the most common actions such as 
moving, copying, renaming or sending to the Wastebin/Trash can be undone. On the Menu bar, go to Edit > 
Undo or click the Control button > Undo. The action to be undone is often described on the menu, e.g. 
"Undo: Move". The common keyboard shortcut Ctrl+Z is also applicable here.

Reminder: Moving items to the Wastebin can be undone, if the size and time limits are not exceeded (see 
the Wastebin (Trash) category under the section Configuring Dolphin for details). However, deleting an item
cannot be undone.

Opening a file with an application

Generally you can just click on a file such as an office document, an image or an XML file in order to open it 
in the appropriate application (a single or double click may be necessary according to your setup). If this 
works as you want it to, then you need do nothing else.

However, this is not always the case. In some instances the wrong application is used – at least wrong for 
what you want to do with the file – or no default application has been specified. In such circumstances, you 
can right-click on the icon of the file you want to open and get a context menu that offers some additional 
options.

In Figure 27 the context menu shows multiple applications that you could use with the highlighted item, in 
this case an Open Document Text (ODT) file. The one at the top is the default. In this example, because the 
default application Okular is only a viewer, you may want to open the file with OpenOffice Writer in order to 
edit it. Simply right-click on the file, navigate on the pop-up menu to Open With, and from the submenu select
OpenOffice.org Writer.

Setting the default application for a file type

You can easily change the default application to use with any given file type, or add a new one. Although the 
above method works fine if you want to select an application other than the default on certain occasions, if 
you do this regularly you might want to change this setting permanently.
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Firstly, if the application isn't listed in the Open With submenu when right-clicking on the file, the simplest way
to proceed is to click Other... at the bottom of this submenu, which will present a picker dialog box. Under 
some desktop environments, this will be the standard file selector which is not always intuitive, and you are 
expected to know where to locate the binary executable on your file system (hint: it's usually in /usr/bin).

Under the Plasma Desktop, this is made easier, since you are presented with a list of applications similar to 
the grouping in the main menu (see Figure 28, above). Click the arrow indicators to expand a category and 
select the preferred application. If it's not listed, type the application name in the text field at the top, or locate
the executable file using the Browse button to the right of this text field. A checkbox at the bottom of the 
dialog offers to remember the application association for this type of file. Check this and click OK.

Alternatively, and for more options, select a file of the type you want to modify, e.g. a JPEG image, and from 
the Menu bar, click File > Properties. This particular function is not found on the Control button menu, but it 
can be invoked from a right-click on the file, then selecting Properties from the pop-up context menu, or by 
using the keyboard combination Alt+Enter. A dialog box appears. Under the General tab, some 
information is provided about the selected file, including the file type, below which is a button, labeled File 
Type Options. Click on this button.

An additional dialog is shown as seen in Figure 29, below. It contains the default icon and a list of file types 
that form part of the same group.

The Description in this dialog is an editable field that will affect how the file type is referred to within Dolphin 
and perhaps elsewhere on your system. Underneath, the Application Preference Order shows all 
applications that are registered to open this type of file. If you click on an entry in this list, you can move it up 
or down in the order (if there is more than one application). The application at the top of the list will be the 
default, meaning that when you click on a file of this type in the workspace, it will open it with that application;
the others will appear on the Open With contextual menu.

It is possible to remove any of these entries, or to edit one, but the latter option's configurations can be quite 
advanced. To add a new application, click the Add... button, which will bring up the picker dialog box as seen 
in Figure 28 above. Browse the categories and select the new application, then click OK to return to the 
previous dialog, where it will be placed at the top of the list as the default. Click OK twice more to exit the two
initial dialogs and return to the main Dolphin window.
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One other thing you might want to change in the File Type Options dialog is the default icon, which will affect 
all files of that type on your system, not just the one you have selected. Under the General tab, the icon you 
see is clickable, as seen in Figure 29 above. Clicking it will bring up a new dialog to select from amongst the 
many icons used or available on your system. The mimetypes icon category is shown by default, but you can
select other categories, or you can browse to an icon you have stored elsewhere. When you have made your
choice, click OK three times to exit the various dialogs.

Changing the icon for a folder

Similar to the process mentioned in the paragraph above, you can also change the icon used for folders. If 
you want to change all folder icons to something other than the default, select any folder and bring up the 
Properties dialog by going to the Menu bar > File > Properties, or by using the keyboard combination 
Alt+Enter. Next, click the File Type Options button to invoke a second dialog, where you can click the icon 
shown to change the default for the "inode/directory" file type (a "folder", essentially). Note that any folders 
you have already customized with something other than the default icon will remain unaffected.

To change the icon for a specific folder, the process is similar but subtly different. Select the relevant folder 
you wish to customize, and follow the instructions above to bring up the Properties dialog. This time, you do 
not need to click the File Type Options button, simply click instead the icon shown to the left of the folder 
name. You will be presented with an identical icon selection dialog to that mentioned above. When you've 
made your selection, click OK twice to exit both dialogs, and your folder will have its own individual icon.

It is important not to confuse the two above processes. To clarify:

• To change a single folder icon, invoke the Properties dialog, then click the icon in that dialog.
• To change all folder icons, or all icons for a particular file type, invoke the Properties dialog, then 

click the File Type Options button, and then click the icon in that second dialog.

Customized folder icons can be particularly useful for key folders you use regularly, such as those in your 
Places. Figure 29, above, shows several such Places with special icons that have been set this way.
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File ownership and permissions

Whilst you can view the owner of files and folders and the permissions settings directly within the workspace 
by selecting from the Additional Information options, or by using the Information panel, in order to modify 
these settings you need to invoke a separate dialog. This is reached by the same method as the dialog for 
setting the default application for a file type, explained previously.

Select the file(s) or folder(s) you wish to modify, then go to the Menu bar > File > Properties, or right-click the
selected item(s) and from the context menu click Properties. The key combination Alt+Enter can also be 
used. In the resulting dialog, click the Permissions tab.

The following details assume you are using a Linux or Unix-like system, the latter category of which can 
include BSD, Mac OS X or Solaris. Windows uses a different concept for permissions settings.

Under the Access Permissions heading, there are drop-down boxes for setting the read/write status for the 
three basic classes of Owner, Group and Others, with a separate checkbox to make the item(s) executable. 
When the selected item is a folder, this checkbox is instead for setting special permissions whereby only the 
owner of the folder can rename and delete its content.

For some hidden configuration files, and for most other locations on the file system outside of /home, the 
owner will likely be the root user (administrator). Only root can modify the ownership and permissions 
settings for these files.

As the owner, you will almost certainly always want at least Read (r) permissions for files and folders in your 
own home directory. If you wish to modify or overwrite any file you own, it should also be set to have Write 
(w) permissions for the user. For folders, you need Execute (x) permissions to enter the folder and view its 
contents. Execute permissions are not so necessary for many other files on typical Linux or Unix file 
systems, except those representing applications, shell scripts and other executable programs.

The Advanced Permissions button provides access to fine-tuned settings including options to set the user ID,
group ID or the "sticky bit", and to create your own user-defined permissions.

The Ownership section underneath shows to which User and Group the item belongs. If you are the owner of
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the selected item(s), you can modify these settings (see Figure 30, above). When the selected item is a 
folder, you can also check a box to apply your changes to all of its subfolders and their contents.

Linux file ownership and permissions is a topic too vast to explain in this guide. The Wikipedia page on File 
system permissions is a good starting point for further information on the subject.

Using the Find function

Dolphin's tools for finding files and folders have undergone some changes. The earlier versions contained a 
Find command that invoked a separate dialog, which was replaced by inline search tools above the 
workspace. In more recent versions of the application, the Places panel also contains some default search 
functions, which are explained in the next section.

To initiate a file search, go to the Menu bar > Edit > Find..., or click the Control button, then Find..., 
whereupon a search bar will appear above the workspace. You can also use the key combination Ctrl+F to 
launch the Find function. Type the search term into the text box to the right of where it says Find: and if you 
want to erase the contents of the search box, there is a standard symbol for clearing text fields at the right-
hand end of the box (the white cross on a black background in Figure 31, below), which you can click on.

Typing more than one word will cause Dolphin to search for that exact phrase, rather than all of the words 
appearing anywhere within the same file. Depending on the speed of your system and how much data is on 
it, this could take some time. You can stop the search by clicking the button on the Status bar next to the 
busy indicator. If you hover the mouse pointer over this button, the tooltip says "Stop loading."

Wildcards can be used inside a search term to denote one or more variable characters. The question mark 
(?) symbol represents one single unspecified character, whilst the asterisk (*) denotes any number of 
unspecified characters, including none at all.

Hence, if you are searching for all JPEG images with a file extension of .jpg or .jpeg amongst an assortment 
of other documents, a search for the string jp?g would show only those with the .jpeg extension (in addition 
to any file with another random character in between the letters "jp" and "g"), whereas using the string jp*g 
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would show both .jpg and .jpeg files (plus all files with any number of characters in between the letters "jp" 
and "g").

Unlike with the Filter bar, surrounding wildcards are not required when using the Find command. This means
that searching for the string l*nk would find not just files named "link", for example, but also "blanks" or 
even "Dolphin_thank_you.txt". The search string you type can feature anywhere within a file or folder name.

Underneath the search box you will see additional options. The first pair of buttons to the upper left is 
Filename and Content. You can only select one or the other. This determines whether Dolphin will search for 
your term(s) in just filenames, or whether it will search not just the filenames but also the contents of files. 
Dolphin is able to retrieve text strings from many sorts of files, not just text documents.

Note that selecting to search file Content requires Dolphin to scour larger amounts of data, so this is where 
things can slow down. However, if you are running Dolphin under the Plasma Desktop and have its file 
indexing tools enabled, this process will be more rapid and consume less resources because the bulk of your
system's files will already have been analyzed.

The next pairing of buttons (again, choosing one deselects the other), lets you search either From Here, 
meaning from the current directory and all levels below it (the subdirectories), or Everywhere, meaning the 
user's entire home directory. (If you have the older Nepomuk/Strigi indexing tools enabled, this second option
searches all indexed folders instead).

If you are not the root user (administrator) and try to search from / (the file system root), then not all files on 
the system will be searched because some parts of it are inaccessible to regular users. You will also not be 
able to search within other users' home directories on a multi-user system unless they are configured with 
group or other permissions allowing you to do so. Removable drives are not searched by default.

Clicking on the More Options button lets you hone your search to achieve more fine-grain results. Additional 
columns of filters are shown, augmenting your search capabilities to limit the results by file type, date or 
rating. However, you need the semantic desktop and/or file indexing features to be enabled and activated for 
these filters to be usable.

The results of your search are shown in the workspace below. You can manipulate these items just as you 
would when browsing your file system normally in Dolphin, i.e. make selections and perform actions. To exit 
the search tool and close the search bar, click the close icon to the left of the search box. If you hover the 
mouse pointer over this icon, the tooltip says "Quit searching."

Additional search tools

More recent versions of Dolphin have incorporated extra search and filtering functionality into the Places 
panel, as seen in Figure 32, below. Under the heading "Search For", you can look for the same categories of 
files mentioned previously via the More Options button, e.g. Documents, Images, Audio Files or Videos. This 
provides a shortcut route to those filters.

Another feature in this panel is a set of filters based on the document modification date. Under "Recently 
Saved", you can search for files or folders that were last modified Today, Yesterday, This Month or Last 
Month. The latter two of these categories provide a tree-like breakdown of files divided into individual days of
the month, rather similar to the Show in Groups > by Date function.

Unlike the file type filters, when you click on one of these Recently Saved categories there is no search box 
with additional options provided above the workspace.
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Although earlier versions of Dolphin did not feature these Recently Saved filters by default in the Places 
panel, if you are using the Plasma Desktop's file indexing features, the functionality can be accessed in an 
additional way. Set your Location bar to Editable Location mode, clear the contents, then type timeline: 
and press Enter. This makes use of the timeline KIO slave to categorize files in the workspace by date.

Note that in the example provided in Figure 32, above, there are some minor glitches with the translations on
this multi-language installation, evident from the Franglais references to "Last vendredi" and other mixed-up 
terms. These are small bugs that should be addressed in future releases.
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Expanding Dolphin

There are many advanced configurations, add-on services and optional components that can enhance your 
use of Dolphin and improve its functionality. Here are just a few suggestions:

Using Dolphin in Super User Mode: Depending on your Linux distribution or operating system, you may 
find a listing in your Applications menu for "File Manager – Super User Mode". If Dolphin is your default file 
manager, selecting this will launch a version of the application running as the root user (administrator). If you 
are not the system administrator, you will first be prompted for the root password. When running Dolphin in 
this mode, you will not see your regular list of Places and other personalizations since root uses a separate 
configuration. The theming of the application may also appear different. This mode provides easy 
management of system files for doing administrative tasks. Take extra care not to accidentally move or 
perform actions on system files and folders, and do not confuse the application with regular user instances of
Dolphin. Opening, modifying or deleting files as root user can be hazardous and cause system instabilities.

Semantic desktop and file indexing integration: At several places in this guide, references have been 
made to additional features that depend upon other components being enabled and active in your desktop 
environment. Users of the Plasma Desktop can integrate file indexing services to provide better search and 
filtering functionality. The semantic desktop features previously relied upon a technology known as 
Nepomuk. Under the new KDE Frameworks, indexing is performed by Baloo.

Enabling these components provides the possibility to tag files, add comments and ratings, and to search 
and filter by more criteria. Go to the Search or Desktop Search category in the Plasma System Settings to 
activate these features.

Add new Dolphin components: Some additional functions can be installed directly from within Dolphin, as 
detailed for example under Services in the section Configuring Dolphin, where new actions can be added to 
the context menu by downloading from a dedicated resource. Other components can be downloaded from 
the Internet and installed independently. See the KDE-apps resource for some suggestions. Your Linux 
distribution might also include some of these and other packages that can be installed using your regular 
package manager (software installation tool). There are many such third-party add-ons available.

Integrate Dolphin with Git and other Version Control Systems (VCS): If you're a developer, you'll find 
various tools created for Dolphin that integrate with version control systems such as Git, SVN, Bazaar, 
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Figure 33: Dolphin running in Super User Mode.
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Mercurial, etc., allowing you to checkout and make commits directly within the Dolphin interface.

Use KIO slaves for network-transparent access to resources: Dolphin can make use of KDE 
Input/Output (KIO) slaves, which provide a single, consistent interface through which to access both local 
and remote resources. Like with SVN repositories mentioned above, you can access Samba shares, use 
FTP or SSH to navigate across networks, or simply view a list of locally installed applications or bookmarks. 
There are dozens of KIO slaves available in Dolphin to save you using separate applications for every task.

To discover the KIO slaves that are available, set your Location bar to Editable mode. If it isn't already in this 
mode, click the blank area at the right-hand end of the Location bar. Now clear the contents of the Location 
bar by clicking the small cross symbol at the right-hand end. The word "file" with a downwards pointing arrow
will now appear at the left-hand end of the Location bar. Click on this to see a drop-down menu of KIO 
slaves.

In addition to network-centric FTP, NFS, Samba (smb) and SSH (fish) protocols, there are KIO slaves for the 
local machine, such as direct access to system settings modules, browsing of installed applications and 
fonts, attached devices, and a large number of additional options under the Other category. The available 
options will be expanded by certain other KDE applications and components you have installed on your 
system.

Network folders and connections

Despite the main focus of Dolphin being the navigation of the local file system, that being the files and folders
on the machine you're directly interfacing with, the application also provides numerous methods of accessing
remote machines, be they connected via a direct wired or wireless link, across a LAN (Local Area Network), 
or over the Internet. The initial setup procedures for such connections are diverse and it would not be 
possible to detail each of them individually here. However, assuming you have already configured additional 
network settings independently, many common connections can be accessed via Dolphin to enable remote 
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Figure 34: Clear the Editable Location bar to see a drop-down menu titled "file", containing a list of KIO slaves.



viewing, transfer and management of files.

Dolphin integrates an array of remote services and connections into its Network menu, normally found by 
default as an item on the Places panel. This is a virtual folder, meaning that it is not a real location but a 
compilation of resources presented like a regular folder. If you do not have the Places panel activated, it can 
also be accessed by typing remote: into the Editable Location bar and pressing Enter. A default menu will 
be shown in the workspace, containing links to items such as MTP Devices and Samba Shares.

For other types of network connections, whilst some preliminary configuration is generally necessary, 
Dolphin can assist with the final steps in order to create a convenient shortcut for future use. The following 
example using SSH (Secure Shell) assumes you have set up (Open)SSH by modifying necessary 
configuration files on both the local and remote machine, opening the relevant ports in the firewall(s), where 
necessary, then enabling and activating (or restarting) the SSH daemon. Many of the configuration options 
are similar for other types of connections.

Click the Network icon in the Places panel, then click the Add Network Folder item in the workspace. The 
dialog for the Network Folder Wizard, also known as "KNetAttach", is now shown. Amongst the list of 
options, there is the possibility to re-establish a recent connection, regardless of whether you created a 
shortcut for it previously. Alternatively, select the type of network folder, which for this example is Secure shell
(ssh), then click Next. Fill in the connection information as follows:

Name: You can enter any name for use as a reference, and this will be assigned to the connection shortcut.
User: Enter the username (account login name) that is making the connection.
Server: Enter the address of the machine you are accessing. This can be either a domain name or an IP 
address (you do not need to enter the http:// or other prefix).
Port: The number of the port as specified in the configuration files. The default is already shown. For SSH, 
this is 22. This parameter does not apply to Samba folders.
Protocol: Select either the SFTP or fish (SSH) option.
Folder: Enter the path of the default folder you wish to view on the remote machine. This might be / or 
/home/{username}/

A comprehensive guide to the Dolphin file manager – page 48 – Expanding Dolphin

Figure 35: The second step in the Network Folder Wizard, also known as KNetAttach.



Encoding: Select the encoding for the remote device's file system. This setting can be modified during an 
active connection by going to the Menu bar > Tools, or clicking the Control button > Tools, and selecting from
the Remote Charset submenu.

Lastly, there is a checkbox for creating an icon for this remote folder, which will add a shortcut to this 
connection in your Network menu. This can be edited or deleted later if required. When choosing the 
WebFolder (webdav) connection, there is an additional option shown to use encryption for a secure 
connection.

Click on Save & Connect. You may be prompted to enter a password, depending on the type of 
authentication you have configured. If you chose to create an icon for the connection, simply click on this in 
future for immediate access to the remote resource. To bookmark the connection in your list of Places, right-
click this icon and from the context menu, select Add to Places.

You can edit an existing connection's name or default folder path, by right-clicking the icon and selecting 
Properties from the context menu. In the resulting dialog, you can overwrite the existing name or modify the 
folder the link points to, then click OK.
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Tips and tricks

Here are a few assorted tips that can make using Dolphin easier and more productive:

Optimize screen space: If you don't frequently change the items in the Places panel, first check if some of 
these Places can be given shorter names. Remember, shortening the name displayed here does not affect 
the actual name of that folder. Now, drag the divider between the Places panel and the workspace until all 
the Places names are still shown in full without being cut off, and hence no horizontal scrollbar appears 
underneath. You can drag the other dividers if desired, in addition to the window borders, to get your 
preferred sizing. If using Dolphin under the Plasma Desktop, the KWin window manager remembers the 
window size settings each time you start the application.

Right-click everywhere: There are many 
shortcut ways of performing actions in Dolphin. 
Invoking the context menu through a right-click 
(assuming your mouse/touchpad is operating in 
right-handed mode), or via the Menu key on the 
keyboard from whatever item has focus, can 
produce very useful options that save you from 
navigating several menus or configuration 
dialogs. Almost every area in the Dolphin 
interface has some relevant functions applicable
to it, accessible by right-clicking at that spot. So 
right-clicking on a tab above the workspace 
brings up a contextual tabs menu where you can
open a new tab, detach or close the current tab, 
or close the other tabs. Try experimenting with 
right-clicks and you will find new ways to 
achieve things more efficiently.
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Figure 36: When choosing the Toolbar option Text Alongside Icons, you can set 
button labels individually.

Set button labels individually: The buttons on the Toolbar can 
be displayed with either icons, text labels, or both. The size of 
the icons and relative position of the text labels can be modified. 
You might find some icons are instantly recognizable whilst 
others are easy to get confused, so a text label can help with 
identification, whilst elsewhere you can save space and clutter 
by showing just the icon. Right-click on the Toolbar and you will 
see a contextual menu containing options for the Text Position 
and Icon Size. When choosing the option Text Alongside Icons, 
every Toolbar button has an option to set individually whether to 
show its text label. Right-click on each button and check or 
uncheck the box under the heading, "Show Text".

Figure 37: Hold down the Shift key whilst displaying the right-click context menu for a 
file or folder, and the option Move to Wastebin will toggle to show Delete.

Quick switch between Wastebin and Delete: When you right-click 
on any file(s) or folder(s), the default context menu shows an entry 
Move to Wastebin (or Move to Trash, depending on locale). This 
function is safer than deleting as you may be able to retrieve the files 
from the Wastebin later if you make a mistake or change your mind. 
However, there are times when you are absolutely sure you want the 
option to instantly delete. Whilst this context menu is activated, hold 
down the Shift key, and the entry Move to Wastebin will change to 
Delete. Releasing the Shift key toggles back to its original state.

Figure 38: Right-clicking brings up a contextual menu. Here, right-clicking
a mounted removable device offers an option to unmount it, amongst 
other entries.



Concluding notes

As the default GUI file manager for the Plasma Desktop, many people encounter Dolphin and never explore 
it beyond the bare minimum necessary to perform the most basic file management tasks. Hopefully, this 
guide has provided you with some insight into the many powerful features available in Dolphin, and it will 
enable you to more fully utilize this very capable tool.

This document does not cover every conceivable function but provides an overview of the majority that are 
not dependent on supplementary tools or applications. As with most other KDE Applications, Dolphin is as 
configurable and versatile as you want it to be. Find the way of working with it that suits you best. The choice
is yours.
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