Problems with JetPack 4.8

If you are using WordPress and have JetPack installed, do not under any circumstances install JetPack 4.8 at this time. JetPack 4.8 causes significant problems. It apparently prevents loading of all plugins and prevents the site from working.

I reverted back to JetPack 4.7.1 which resolved the problem.

I will post an update to this story when there is a fix available.